Infocell
 
 
 
 
 
 

OMFEL - oumbärlig funktion

 

Felvärden i Excel är de flesta användare bekanta med eftersom de förr eller senare dyker upp. Det kan t ex vara #VÄRDEFEL!, #DIVISION/0!, #NAMN? eller #SAKNAS!

Värdena ser många gånger skrämmande ut och förstör definitivt utseendet i din kalkyl eller rapport.

 

Om du vill råda bot på detta problem ska du använda dig av funktionen OMFEL. Funktionen returnerar ett värde som du anger om en formel utvärderas till ett fel. Annars returneras formelresultatet.

 


 

prislista e-learning


 

 

Ett exempel:

 

i cell  har du värdet 100 och i cell A2 värdet 0. i cell A3 har du en formel som säger =A1/A2 (d v s 100/0). Utfallet av formeln i cell A3 blir #DIVISION/0!. Genom att använda funktioen OMFEL kan vi välja vilket värde som ska visas istället för felvärdet #DIVISION/0!. Om vi i cell A3 istället använder funktionen OMFEL enligt följande:

=OMFEL(A1/A2;0)

Då blir utfallet i cell A3 istället 0.

 

Nedan ses en sammanställning av sex avdelningars kostnader och nedlagda timmar. Längst til höger beräknas också kostnader per timme. För Avdelning 44 finns kostnader, men inga timmar registrerade. Detta genererar felvärdet #DIVISION/0!. I vår sammanställning vill vi inte visa felvärdet utan istället visa nollvärden om det inte är några timmar registrerade. Detta löser vi med OMFEL-funktionen. Genom att omsluta OMFEL-funktionen runt vår ursprunglia formel (=D5/C5) kan vi visa noll när det är ett felvärde. Du kan givetvis visa valfritt värde vid fel. Vill du visa en textsträng så skriver texten inom citationstecken, t.ex. "N/A".

 

omfel

 

Funktionen OMFEL introducerades med Excel 2007. I tidigare versioner är man tvungen att använda en kombination av OM-funktionen och ÄRFEL-funktionen.

 

Formelsyntax: OMFEL(värde; värde_om_fel)

 

Argument

  • Värde Obligatoriskt. Detta är det argument som genomsöks efter fel.
  • Värde_om_fel Obligatoriskt. Detta är det värde som returneras om formeln utvärderas till ett fel. Följande feltyper utvärderas: #SAKNAS!, #VÄRDEFEL!, #REFERENS!, #DIVISION/0!, #OGILTIGT! och #NAMN?.

 

www.infocell.se

Dela på Facebook Dela på MySpace Dela på Pusha Dela på Twitter